Browser Check
Requirements Test Your Browser

Javascript MUST be enabled to use Blackboard!

Below are the current minimum requirement for using Blackboard Learn at Saint Louis Community College.
 
A current, non-tablet computer is recommended for full use of Blackboard. Tablets will work for some features but are not supported for all content, assessments, grade center, etc... Blackboard's Browser Support Document is available here.
 
You will need 1 of the following operating systems:
  • Windows XP
  • Windows Vista
  • Windows 7
  • Windows 8
  • Mac OSX 10.6 (Snow Leopard)
  • Mac OSX 10.7 (Lion)
  • Mac OSX 10.8 (Mountain Lion)
  • Mac OSX 10.9 (Mavericks)
One of the following internet browsers: and Java Runtime 1.7 with the latest update (1.6 will work but is not supported by Blackboard).
 

The following technologies are not supported:

  • Internet Explorer 6, 7
  • Firefox 1.x, 2.0, 3.0, 3.5, and 3.6
  • Safari 2.0, 3.x and any version on Windows
  • Windows XP64-bit
  • Mac OSX 10.3, 10.4, 10.5
  • Java 5, although it may continue to work